To prevent the reverse engineering of script applications, a number of developers encrypt their program code with instruments such as ionCube PHP Encoder to make it human unreadable. This is valid for paid applications in particular, as anyone would be able to use and modify the unprotected code without paying the required license fees. If you acquire web software encoded with ionCube PHP Encoder, you will be able to use it without any problems as long as a tool called ionCube Loader is present on the web hosting server. This loader enables you to run encoded files and you'll often notice it on the list of prerequisites for a particular script app to be set up. Due to the fact that the encoded files are already precompiled, they're normally executed faster and this can increase the general speed of your site.
IonCube in Cloud Website Hosting
If you aquire a Linux cloud website hosting from our company, it'll be created on our tailor-made cloud hosting platform where ionCube Loader is already installed, so you won't have any problems to manage any script app which needs the instrument to run properly. In addition, we offer you a few different versions of PHP, therefore if you switch the version, you will need to activate ionCube once again. Our system remembers the adjustments you make, so in case you switch back to the earlier version of PHP that was active for your account, ionCube Loader will already be turned on. The PHP version as well as the ionCube instrument can be managed through the PHP Configuration area of our Hepsia hosting Control Panel. Any adjustment that you make takes literally just a click and it'll take effect right away.
IonCube in Semi-dedicated Servers
If you buy a semi-dedicated server plan from us, you can take advantage of any kind of script-driven application which requires ionCube Loader for the reason that the tool is available on all servers which are part of our modern cloud web hosting platform. In addition, we support several releases of PHP, which means that if you switch from PHP 4 to 5.2 or 5.3, for example, you can activate ionCube for that particular release with just a click from your Hepsia Control Panel. Our platform will remember your choice, so in case you switch back to the earlier release of PHP, the software instrument will already be active. For more tech-savvy users, we also offer the option to choose the PHP version and whether ionCube will be active or not for a particular domain without altering the settings for the whole web hosting account. This can be done by placing a php.ini file within a domain folder with a couple of lines of code.